pat

题目

Given a sequence of $K$ integers ${ N_1,..., N_K}$. A continuous subsequence is defined to be ${ N_i, N_i+1, ..., N_j}$ where $1≤i≤j≤K$. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence ${ -2, 11, -4, 13, -5, -2 }$, its maximum subsequence is ${ 11, -4, 13 }$ with the largest sum being $20$.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer $K (≤10000)$. The second line contains $K $numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the $K$ numbers are negative, then its maximum sum is defined to be $0$, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

这个题目乍一看以为是动态规划,但是实际上没那么复杂。用tmp来记录和,如果tmp<0,那么tmp更新,把前面的都丢掉。如果tmp>sum,则用tmp替代sum的信息。
1⃣️输出的是值,不是索引号。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29

#include <vector>
using namespace std;
typedef vector<int> vi;
int (){
int K;
scanf("%d", &K);
int tmp = 0, sum = -1, tmp_left = 0, left = 0, right = K-1;
bool flag = true;
vi N(K, 0);
for(int i = 0;i < K;i++){
scanf("%d", &N[i]);
if(N[i]) flag = false;
tmp += N[i];
if(tmp < 0){
tmp_left = i + 1;
tmp = 0;
}else if(tmp > sum){
sum = tmp;
left = tmp_left;
right = i;
}
}
if(sum < 0) sum = 0;
if(!flag)
printf("%d %d %d", sum, N[left], N[right]);
else printf("0 0 0");
return 0;
}