pat

题目

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

$K$ $N1$ $a{N1}$ $N2$ $a{N2}$ ... $NK$ $a{NK}$
​​
where $K$ is the number of nonzero terms in the polynomial, $N_i$ and $a_Ni$ ($i=1,2,⋯,K$) are the exponents and coefficients, respectively. It is given that $1≤K≤10$,0≤$N_K$<⋯<$N_2$<$N_1$≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

这个题目要注意的地方就是,虽然$K$小于等于10,但是中间的$N_i$是最大能到1000的。
另外:一开始把vector<double>开的是1000,然后下面for(i=1000...),这样直接是答案错误,而不是运行错误。

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32

#include<iostream>
#include<vector>
using namespace std;
vector<double> V(1001, 0);
int (){
int K1, K2, temp1;
double temp2;
scanf("%d", &K1);
int maxx = -1;
while(K1--){
scanf("%d %lf", &temp1, &temp2);
V[temp1] += temp2;
}
scanf("%d", &K2);
while(K2--){
scanf("%d %lf", &temp1, &temp2);
V[temp1] += temp2;
}
int cnt = 0;
for(int i = 1000;i >= 0;i--){
if(V[i] != 0.0)
cnt++;
}
printf("%d", cnt);
for(int i = 1000;i >= 0;i--){
if(V[i] != 0.0)
printf(" %d %.1f", i, V[i]);
}
return 0;
}