hdoj1021 fibonacci again



Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 72792 Accepted Submission(s): 33298

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word “yes” if 3 divide evenly into F(n).
Print the word “no” if not.

Sample Input

1
2
3
4
5
6
0
1
2
3
4
5

Sample Output

1
2
3
4
5
6
no
no
yes
no
no
no

Author

Leojay

Code

这是一道规律题,将Fibonacci数列对3取模输出后,可以发现是一个周期为8的数列.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39

int ()
{
freopen("in.txt", "r", stdin);
int n;
while(~scanf("%d", &n))
if(n % 8 == 2 || n % 8 == 6) printf("yesn");
else printf("non");
return 0;
}

错误的代码
#include <iostream>
using namespace std;
const int maxn = 1000000 + 5;
long long fi[maxn];
int main()
{
freopen("in.txt", "r", stdin);
int fin = 2;
int n;
fi[0] = 7;
fi[1] = 11;
while(~scanf("%d", &n))
{
if(fin <= n)
{
for(int i = fin; i <= n; i++)
fi[i] = fi[i - 1] + fi[i - 2];
fin = n;
}
if(fi[n] % 3 == 0)
printf("yesn");
else
printf("non");
}
return 0;
}
*/