zcmu2188 frames

ZCMU2188 Frames(多情况模拟讨论)

Description

Throughout Igor K.’s life he has had many situations worthy of attention. We remember the story with the virus, the story of his mathematical career and of course, his famous programming achievements. However, one does not always adopt new hobbies, one can quit something as well.

This time Igor K. got disappointed in one of his hobbies: editing and voicing videos. Moreover, he got disappointed in it so much, that he decided to destroy his secret archive for good.

Igor K. use Pindows XR operation system which represents files and folders by small icons. At that, m icons can fit in a horizontal row in any window.

Igor K.’s computer contains n folders in the D: disk’s root catalog. The folders are numbered from 1 to n in the order from the left to the right and from top to bottom (see the images). At that the folders with secret videos have numbers from a to b inclusive. Igor K. wants to delete them forever, at that making as few frame selections as possible, and then pressing Shift+Delete exactly once. What is the minimum number of times Igor K. will have to select the folder in order to select folders from a to b and only them? Let us note that if some selected folder is selected repeatedly, then it is deselected. Each selection possesses the shape of some rectangle with sides parallel to the screen’s borders.

Input

The only line contains four integers n, m, a, b (1≤n,m≤109, 1≤abn). They are the number of folders in Igor K.’s computer, the width of a window and the numbers of the first and the last folders that need to be deleted.

Output

Print a single number: the least possible number of times Igor K. will have to select the folders using frames to select only the folders with numbers from a to b.

Examples Input

1
11 4 3 9

Examples Output

1
3

Note

Note

The images below illustrate statement tests.

The first test:

img

In this test we can select folders 3 and 4 with out first selection, folders 5, 6, 7, 8 with our second selection and folder 9 with our third, last selection.

The second test:

img

In this test we can first select all folders in the first row (2, 3, 4, 5), then − all other ones.

思路

挺有意思的模拟题,考虑多种情况,最终结果将是1次2次3次,具体讨论看代码即可

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30

#include <iostream>
using namespace std;
int ()
{
long long n,m,a,b;
while(cin>>n>>m>>a>>b)
{
int st=a/m+(a%m!=0);int ed=b/m+(b%m!=0);
if(m==1)
{
cout<<1<<endl;
continue;
}
if(b==n)
{
if(a%m==1||st==ed) cout<<1<<endl;
else cout<<2<<endl;
continue;
}
if((a%m==1&&b%m==0)||st==ed)
{
cout<<1<<endl;
continue;
}
if(a%m==1||b%m==0||st+1==ed||(b+1)%m==a%m) cout<<2<<endl;
else cout<<3<<endl;
}
return 0;
}