poj Input Output Sample Input Sample Output 题目大意 思路 代码

传送门: POJ-1751

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.


Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input

1
2
3
4
5
6
7
8
9
10
11
12
13
14
9
1 5
0 0
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1
2
3
4
5
1 6
3 7
4 9
5 7
8 3

题目大意

题目的意思就是给你所有点的坐标和已经有的边,让你找一个新建边权最小的无向连通图,并且新建的边的路径。

思路

题目的意思很明显是求最小生成树,只不过给了一些已有的边,因为已有的边不需要花费,所以这些边的权值可以记为0,还有一个问题就是路径打印,我用的是prim算法,我们可以用一个数组来存放,每一个节点的前驱节点,记pre[i] = u,代表i的前驱节点是u,我们可以在dis[i] > e[u][i]时,将dis[i]更新为e[u][i],并更新pre[i] = u,这样每次我们在添加点时打印路径。

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79

> File Name: highway.cpp
> Author: TSwiftie
> Mail: [email protected]
> Created Time: Tue 16 Jul 2019 03:42:47 PM CST
************************************************************/


#include <string>
#include <cstring>
#include <cstdio>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <algorithm>
#include <cstdlib>
#include <cmath>
#include <vector>
//#include <unordered_map>
using namespace std;
typedef long long ll;
typedef pair<double, int> P;
const int INF = 0x3f3f3f3f;
const int MAXN = 800;
int n, m;
double e[MAXN][MAXN];
double dis[MAXN];
int pre[MAXN];
bool vis[MAXN];
int x[MAXN],y[MAXN];
void ()
{
//初始化距离,将每个点的前驱节点初始化为1
memset(vis,0,sizeof(vis));
for(int i = 0; i <= n; i++)
dis[i] = INF*1.0, pre[i] = 1;
dis[1] = 0;
priority_queue<P, vector<P>, greater<P> >q;
q.push(P(dis[1], 1));
while(!q.empty()){
P cur = q.top();
q.pop();
int u = cur.second;
if(vis[u])
continue;
vis[u] = true;
//如果不是已有边且可达就打印路径
if(e[pre[u]][u]!=0 && e[pre[u]][u]!=INF)
printf("%d %dn",pre[u],u);
for(int i = 1; i <= n; i++)
if(e[u][i] < dis[i]){
dis[i] = e[u][i];
q.push(P(dis[i], i));
//更新前驱节点
pre[i] = u;
}
}
}
int main(void)
{
memset(e,INF,sizeof(e));
int st, ed;
scanf("%d",&n);
for(int i = 1; i <= n; ++i)
scanf("%d %d",x+i,y+i);
scanf("%d",&m);
//已有边置为0
for(int i = 1; i <= m; ++i){
scanf("%d %d",&st,&ed);
e[st][ed] = e[ed][st] = 0;
}
for(int i = 1; i < n; ++i)
for(int j = i + 1; j <= n; ++j)
if(e[i][j] != 0)
e[i][j] = e[j][i] = sqrt((double)(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
Prim();
return 0;
}