a1016 phone bills

1016 Phone Bills

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-linerecord. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10 
10 
CYLL 01:01:06:01 on-line 
CYLL 01:28:16:05 off-line 
CYJJ 01:01:07:00 off-line 
CYLL 01:01:08:03 off-line 
CYJJ 01:01:05:59 on-line 
aaa 01:01:01:03 on-line 
aaa 01:02:00:01 on-line 
CYLL 01:28:15:41 on-line 
aaa 01:05:02:24 on-line 
aaa 01:04:23:59 off-line 

Sample Output:

CYJJ 01 
01:05:59 01:07:00 61 $12.10 
Total amount: $12.10 
CYLL 01 
01:06:01 01:08:03 122 $24.40 
28:15:41 28:16:05 24 $3.85 
Total amount: $28.25 
aaa 01 
02:00:01 04:23:59 4318 $638.80 
Total amount: $638.80

解答

#include <bits/stdc++.h>
using namespace std;

int toll[24]; 

struct Record
{
    char name[21];
    int MM, dd, hh, mm;
    bool status; //on-line or off-line
} record[1001], temp;

bool cmp(Record r1, Record r2)
{
    int val = strcmp(r1.name, r2.name);
    if (val != 0)
        return val < 0;
    else if (r1.MM != r2.MM)
        return r1.MM < r2.MM;
    else if (r1.dd != r2.dd)
        return r1.dd < r2.dd;
    else if (r1.hh != r2.hh)
        return r1.hh < r2.hh;
    else
        return r1.mm < r2.mm;
}

void get_expense(int start, int end, int &minute, int &money)
{
    temp = record[start];
    //计算时长
    while (temp.dd < record[end].dd || temp.hh < record[end].hh || temp.mm < record[end].mm)
    {
        minute++;
        temp.mm++; //当前时间加1min
        money += toll[temp.hh];
        if (temp.mm >= 60)
        {
            temp.mm = 0;
            temp.hh++;
        }
        if (temp.hh >= 24)
        {
            temp.hh = 0;
            temp.dd++;
        }
    }
}

int main()
{
    for (int i = 0; i < 24; i++)
        scanf("%d", &toll[i]);

    int N;
    scanf("%d", &N);
    char line[10]; //临时存放on-line or off-line
    for (int i = 0; i < N; i++)
    {
        scanf("%s %d:%d:%d:%d %s", record[i].name, &record[i].MM, &record[i].dd, &record[i].hh, &record[i].mm, line);
        if (strcmp(line, "on-line") == 0)
            record[i].status = true; //on-line
        else
            record[i].status = false; //off-line
    }
    sort(record, record + N, cmp);
    int on_line = 0, off_line, next; //next为下个用户
    while (on_line < N)
    {
        int need_print = 0; //是否配对,输出该用户
        next = on_line;        //从当前位置寻找下一个用户
        while (next < N && strcmp(record[next].name, record[on_line].name) == 0)
        {
            if (need_print == 0 && record[next].status)
                need_print = 1; //找到on-line
            else if (need_print == 1 && !(record[next].status))
                need_print = 2; //找到off-line

            next++; //直到找到下一个不同的名字
        }
        if (need_print < 2) //没有找到配对的off-line
        {
            on_line = next;
            continue;
        }
        int all_expense = 0;
        printf("%s %02dn", record[on_line].name, record[on_line].MM);
        while (on_line < next) //该用户配对的所有账单
        {
            while (on_line < next - 1 && !(record[on_line].status && !(record[on_line + 1].status)))
                on_line++;
            off_line = on_line + 1;
            if (off_line == next) //输出完所有的配对
            {
                on_line = next;
                break;
            }
            printf("%02d:%02d:%02d ", record[on_line].dd, record[on_line].hh, record[on_line].mm);
            printf("%02d:%02d:%02d ", record[off_line].dd, record[off_line].hh, record[off_line].mm);

            int minutes = 0, expense = 0;
            get_expense(on_line, off_line, minutes, expense);
            all_expense += expense;
            printf("%d $%.2fn", minutes, expense / 100.0);
            on_line = off_line + 1; //完成一个配对
        }
        printf("Total amount: $%.2fn", all_expense / 100.0);
    }
    return 0;
}