a1020 tree traversals

1020 Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7 
2 3 1 5 7 6 4 
1 2 3 4 5 6 7 

Sample Output:

4 1 6 3 5 7 2

解答

#include <bits/stdc++.h>
using namespace std;
const int max_n = 31;

struct node
{
    int data;
    node *lchild;
    node *rchild;
};

int in[max_n], post[max_n];
int N; 

node *create(int inL, int inR, int postL, int postR) //创建二叉树
{
    if (postL > postR)
        return nullptr;
    //构建根节点
    node *root = new node;
    root->data = post[postR];
    int k; //根节点在中序的位置
    for (k = inL; k <= inR; k++)
        if (in[k] == post[postR])
            break;
    int num_left = k - inL; //左子树结点的个数
    root->lchild = create(inL, k - 1, postL, postL + num_left - 1);
    root->rchild = create(k + 1, inR, postL + num_left, postR - 1);
    return root;
}

int num = 0; //已输出的结点的个数
void BFS(node *root)
{
    queue<node *> q;
    q.push(root);
    while (!q.empty())
    {
        node *temp = q.front();
        printf("%d", temp->data);
        q.pop();
        num++;
        if (num < N)
            printf(" ");
        if (temp->lchild != nullptr)
            q.push(temp->lchild);
        if (temp->rchild != nullptr)
            q.push(temp->rchild);
    }
}

int main()
{
    scanf("%d", &N);
    for (int i = 0; i < N; i++)
        scanf("%d", &post[i]);
    for (int i = 0; i < N; i++)
        scanf("%d", &in[i]);
    node *root = create(0, N - 1, 0, N - 1);
    BFS(root);
    return 0;
}