a1012 the best rank

1012 The Best Rank

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A 
310101 98 85 88 90 
310102 70 95 88 84 
310103 82 87 94 88 
310104 91 91 91 91 

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6 
310101 98 85 88 
310102 70 95 88 
310103 82 87 94 
310104 91 91 91 
310105 85 90 90 
310101 
310102 
310103 
310104 
310105 
999999 

Sample Output:

1 C 
1 M 
1 E 
1 A 
3 A
N/A

解答

#include <bits/stdc++.h>
using namespace std;

struct Student
{
    int id;
    int grade[4];
} student[2001];

char course[4] = {'A', 'C', 'M', 'E'}; 
int rank_no[1000000][4] = {0};           //每门课对应的排名
int num;                               //按num排序student数组

bool cmp(Student s1, Student s2)
{
    return s1.grade[num] > s2.grade[num];
}

int main()
{
    int N, M;
    scanf("%d%d", &N, &M);
    for (int i = 0; i < N; i++)
    {
        scanf("%d%d%d%d", &student[i].id, &student[i].grade[1], &student[i].grade[2], &student[i].grade[3]);
        student[i].grade[0] = round(student[i].grade[1] + student[i].grade[2] + student[i].grade[3]); //平均分
    }

    for (num = 0; num < 4; num++)
    {
        sort(student, student + N, cmp);
        rank_no[student[0].id][num] = 1;
        for (int i = 1; i < N; i++) //对剩下的学生进行排名
        {
            if (student[i].grade[num] == student[i - 1].grade[num])
                rank_no[student[i].id][num] = rank_no[student[i - 1].id][num];
            else
                rank_no[student[i].id][num] = i + 1;
        }
    }

    int query_id;
    for (int i = 0; i < M; i++)
    {
        scanf("%d", &query_id);
        if (rank_no[query_id][0] == 0) //该学生不存在
            printf("N/An");
        else
        {
            int k = 0; //rank值越小,排名越高
            for (int j = 0; j < 4; j++)
                if (rank_no[query_id][j] < rank_no[query_id][k])
                    k = j;

            printf("%d %cn", rank_no[query_id][k], course[k]);
        }
    }

    return 0;
}