a1025 pat ranking

1025 PAT Ranking

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank 

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2 
5 
1234567890001 95 
1234567890005 100 
1234567890003 95 
1234567890002 77 
1234567890004 85 
4 
1234567890013 65 
1234567890011 25 
1234567890014 100 
1234567890012 85 

Sample Output:

9 
1234567890005 1 1 1 
1234567890014 1 2 1 
1234567890001 3 1 2 
1234567890003 3 1 2 
1234567890004 5 1 4 
1234567890012 5 2 2 
1234567890002 7 1 5 
1234567890013 8 2 3 
1234567890011 9 2 4

解答

#include <bits/stdc++.h>
using namespace std;

struct Student
{
    char id[14]; 
    int score;
    int location_no; //考场号
    int local_rank;  //本考场排名
} student[30001];

bool cmp(Student s1, Student s2)
{
    if (s1.score != s2.score)
        return s1.score > s2.score; //分数从高到低
    else
        return strcmp(s1.id, s2.id) < 0; //准考证号从小到大
}

int main()
{

    int N, K;
    scanf("%d", &N);
    int num = 0; //总考生数
    for (int i = 1; i <= N; i++)
    {
        scanf("%d", &K);
        for (int j = 0; j < K; j++)
        {
            scanf("%s%d", student[num].id, &student[num].score);
            student[num].location_no = i;
            num++;
        }
        sort(student + num - K, student + num, cmp);

        student[num - K].local_rank = 1; //考场第一名

        for (int j = num - K + 1; j < num; j++) //对剩下的人进行排名
        {
            if (student[j].score == student[j - 1].score)
                student[j].local_rank = student[j - 1].local_rank; //分数相同,排名相同
            else
                student[j].local_rank = j + 1 - (num - K);
        }
    }

    printf("%dn", num);
    sort(student, student + num, cmp);
    int rank = 1;
    for (int i = 0; i < num; i++)
    {
        if (i > 0 && student[i].score != student[i - 1].score)
            rank = i + 1;

        printf("%s ", student[i].id);
        printf("%d %d %dn", rank, student[i].location_no, student[i].local_rank);
    }

    return 0;
}