the disjoint set adt

Introduction

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification

Each input file contains one test case. For each test case, the first line contains N (2≤N≤$10^4$), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

1
I c1 c2

where I stands for inputting a connection between c1and c2; or

1
S

where S stands for stopping this case.

Output Specification

For each C case, print in one line the word “yes” or “no” if it is possible or impossible to transfer files between c1and c2, respectively. At the end of each case, print in one line “The network is connected.” if there is a path between any pair of computers; or “There are k components.” where k is the number of connected components in this network.

Sample Input 1:

1
2
3
4
5
6
7
8
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

1
2
3
4
no
no
yes
There are 2 components.

Sample Input 2:

1
2
3
4
5
6
7
8
9
10
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

1
2
3
4
5
no
no
yes
yes
The network is connected.

Solution

这道题就是最基本的Disjoint Set ADT,对于I 便使用union,对于C便对两个节点分别使用Find,然后比较两个节点是不是有同一个root。

对于检查有几个Group,只需要在S之后检查所有点下的-1数量。只有一个root说明全连接,有几个root便是说明有多少个components。

AD Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82

#include "stdio.h"

#define MAX_NUM 10001

void (int S[], int a, int b);
void Connect(int S[], int a, int b);
void Setunion(int S[],int a, int b);
int Find(int S[], int X);

int main()
{
int N;
int S[MAX_NUM];
int i;
char str;
int node1, node2;
int maxcount = 0;


scanf("%d", &N);
// initialization
for (i = 0; i < N + 1; i++)
S[i] = -1;
while (1)
{
scanf("%c", &str);
// getting the Stop signal
if (str == 'S')
{
//printf("n");
break;
}
if (str == 'C')
{
scanf("%d %d", &node1, &node2);
Compare(S, node1, node2);
}

if (str == 'I')
{
scanf("%d %d", &node1, &node2);
Connect(S, node1, node2);
}
}

//
for (i = 1; i < N + 1; i++)
{
if (S[i] == -1)
maxcount++;
}
if (maxcount == 1)
printf("The network is connected.");
else
printf("There are %d components.", maxcount);
system("pause");
}

void Setunion(int S[], int a, int b)
{
S[b] = a;
}

int Find(int S[], int X)
{
for (; S[X] > 0; X = S[X]);
return X;
}

void Connect(int S[], int a, int b)
{
Setunion(S, Find(S, a), Find(S, b));
}

void (int S[], int a, int b)
{
if (Find(S, a) == Find(S, b))
printf("yesn");
else
printf("non");
}