hdoj1856 思路分析

Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input

1
2
3
4
5
6
7
8
9
10
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

1
2
4
2

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

思路分析

本题使用并查集来解决。就是看这题能够形成的最大簇的数量是多少。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42

#include <cstdio>
using namespace std;

const int N = 10000001;

int Tree[N];
int sum[N];

int (int i){
if(Tree[i] == -1) return i;
else{
int temp = FindRoot(Tree[i]);
Tree[i] = temp;
return temp;
}
}

int main(){
int n, a, b;
while(scanf("%d", &n) != EOF){
for(int i=1; i<N; i++){
Tree[i] = -1;
sum[i] = 1; //初始化为1
}
while(n--){
scanf("%d%d", &a, &b);
a = FindRoot(a); // a结点所在的根
b = FindRoot(b);
if(a != b){
Tree[a] = b; //b是根节点!
sum[b] += sum[a];
}
}
int ans = 1; // 至少有1个男孩
for(int i = 1; i < N; i++){
if(Tree[i] == -1 && ans < sum[i]) //搞清楚谁大于,谁小于!
ans = sum[i];
}
printf("%dn", ans);
}
}