pat甲级1002

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

题意:

求两个多项式的和,输入两行,每行第一个是该多项式的项数,接下来依次是每项的指数和系数。如:样例是2.4*x + 3.21.5 * x^2 + 0.5 * x的和,和为1.5 * x^2 + 2.9 * x + 3.2
注意:多项式项数为0,只输出0。某项系数为0时,该项不必输出。

代码:

#include<cstdio>
int main()
{
    const int maxn = 1010;
    double sum[maxn] = {0};
    int n, a, cnt = 0;
    double b;
    scanf("%d", &n);
    for(int i = 0; i < n; ++i){
        scanf("%d%lf", &a, &b);
        sum[a] += b;

    }
    scanf("%d", &n);
    for(int i = 0; i < n; ++i){
        scanf("%d%lf", &a, &b);
        sum[a] += b;

    }
    for(int i = 0; i < maxn; ++i){
        if(sum[i] != 0)
            cnt++;
    }
    printf("%d", cnt);
    if(cnt != 0) printf(" "); 

    for(int i = maxn - 1; i >= 0; --i){
        if(sum[i] != 0 && cnt > 0){
           printf("%d %.1f", i, sum[i]);
           if(cnt > 1)  printf(" ");
           cnt--;
        }

    }

    return 0;

}