pat 甲级 训练真题集 1076! 1076. Forwards on Weibo (30)

1076. Forwards on Weibo (30)

​ 时间限制

​ 3000 ms

​ 内存限制

​ 65536 kB

​ 代码长度限制

​ 16000 B

​ 判题程序

​ Standard

​ 作者

​ CHEN, Yue

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

这道题为图的遍历 bfs,注意层数即可,利用queue进行层次遍历,利用结构体存储节点与所在层数,开始节点层数为0;

代码如下:

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;




int map[1010][1010];
vector<int> m[1010];
int n,l;
struct Node{
	int id;
	int layer;
};
void bfs(int root){
	int collection[1010]={0};
	int cnt=0;
	int num=0;
	queue<Node>q;
	Node no;no.id=root;no.layer=0;
	collection[root]=1;
	q.push(no);
	while(!q.empty()){
		Node top=q.front();
		q.pop();
		for(int i=0;i<m[top.id].size();++i){
			if(collection[m[top.id][i]]==0&&top.layer<l){
				collection[m[top.id][i]]=1;
				Node temp;
				temp.id=m[top.id][i];
				temp.layer=top.layer+1;		
				q.push(temp);
				++num;		
			}		
		}
	}
	printf("%dn",num);
	
}


int main(){
	
	scanf("%d%d",&n,&l);
	int num,next;
	for(int i=1;i<=n;++i){
		scanf("%d",&num);
		for(int j=0;j<num;++j){
			scanf("%d",&next);
			map[next][i]=1;
			m[next].push_back(i);
		}
	}
	int k,q;
	scanf("%d",&k);
	for(int i=0;i<k;++i){
		scanf("%d",&q);
		bfs(q);
	}
	return 0;
}