hdu 1035 robot motion

Robot Motion

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13940 Accepted Submission(s): 6510

Problem Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word “step” is always immediately followed by “(s)” whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0

Sample Output

10 step(s) to exit 3 step(s) before a loop of 8 step(s)

Source

Mid-Central USA 1999

Recommend

We have carefully selected several similar problems for you: 1016 1010 2553 1258 1045

题解

用两个数组,一个数组用来存输入数据,一个数组用来保存路径。初始化保存路径的数组为 -1,每经过一个点路径对应的点加一,为 0 表示经过一次,大于 0 表示经过了不止一次,也就意味着陷入了 loop 中。最后统计路径数组 0 的数量即可得出答案。代码如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <stack>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <utility>
#define ll long long
#define ull_ unsigned long long

using namespace std ;

char mapp[105][105] ;
int road[105][105] ;

int (){
int r , c , pos ;
while ( cin >> r >> c && r + c != 0 && cin >> pos ){
for ( int i = 0 ; i <= r + 1 ; i ++ ){
for ( int j = 0 ; j <= c + 1 ; j ++ ){
road[i][j] = -1 ;
}
}
for ( int i = 1 ; i <= r ; i ++ ){
for ( int j = 1 ; j <= c ; j ++ ){
cin >> mapp[i][j] ;
}
}
int i = 1 , j = pos ;
bool check = false ;
while ( i != 0 && i != r + 1 && j != c + 1 && j != 0 ){
if ( mapp[i][j] == 'N' ){
road[i --][j] ++ ;
}else if ( mapp[i][j] == 'S' ){
road[i ++][j] ++ ;
}else if ( mapp[i][j] == 'E' ){
road[i][j ++] ++ ;
}else{
road[i][j --] ++ ;
}
if ( road[i][j] > 1 ){
check = true ;
break ;
}
}
int step = 0 ;
int loop = 0 ;
for ( int i = 1 ; i <= r ; i ++ ){
for ( int j = 1 ; j <= c ; j ++ ){
if ( road[i][j] == 0 ){
step ++ ;
}else if ( road[i][j] > 1 ){
loop ++ ;
}
}
}
if ( check ){
printf("%d step(s) before a loop of %d step(s)n" , step , loop) ;
}else{
printf("%d step(s) to exitn" , step) ;
}
}
return 0 ;
}