a1058 a+b in hogwarts

1058 A+B in Hogwarts

If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut(Galleon is an integer in [0,10​^7​​], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27 

Sample Output:

14.1.28

解答


#include <bits/stdc++.h>

const int Galleon = 17 * 29;
const int Sickle = 29;

int main()
{
    //数据要声明为long long格式,否则会有一个case因为溢出不通过
    long long p1, p2, p3, a1, a2, a3;
    scanf("%lld.%lld.%lld %lld.%lld.%lld", &p1, &p2, &p3, &a1, &a2, &a3);
    long long P = p1 * Galleon + p2 * Sickle + p3;
    long long A = a1 * Galleon + a2 * Sickle + a3;

    long long sum = A + P;

    printf("%lld.%lld.%lldn", sum / Galleon, sum % Galleon / Sickle, sum % Sickle);

    return 0;
}
//写法二
#include <bits/stdc++.h>

int main()
{
    int a[3], b[3], c[3];
    scanf("%d.%d.%d %d.%d.%d", &a[0], &a[1], &a[2], &b[0], &b[1], &b[2]);

    int carry = 0; //进位
    c[2] = (a[2] + b[2]) % 29;
    carry = (a[2] + b[2]) / 29;
    c[1] = (a[1] + b[1] + carry) % 17;
    carry = (a[1] + b[1] + carry) / 17;
    c[0] = a[0] + b[0] + carry;
    printf("%d.%d.%d", c[0], c[1], c[2]);
    return 0;
}